Fandom

Thai Blender Wiki

บทความ/ทดลองทำ Cloth

< บทความ

105pages on
this wiki
Add New Page
Talk0 Share

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.

Cloth คือการทำผ้า ซึ่งในการทดลองนี้จะเป็นการทำผ้าปลิวไปตามแรงลม โดยหลักสำคัญนั้นจะต้องสร้างจุดยึดให้กับผ้าเพื่อทำให้ผ้าไม่ร่วงหล่น การทำ Cloth ใน Blender นั้นจะมีการสร้างจุดยึดให้เป็น Group และในผ้าผืนเดียวกันนั้น ก็ยังสามารถสร้างจุดยึดให้เป็น Group ได้มากกว่า 1 Group

ปรับ layout และ เตรียมโมเดล Edit

ในการทดลองนี้จะเป็นการทดลองเซ็ตแบบ 1 Group

1.เซ็ต Layout เป็นการทำงานแบบ Animation


2.ใน Blank15x16.gif3D View ปรับ viewport shading เป็น Solid

Cloth การปรับ viewport shading เป็น Solid.png

ปรับ viewport shading ให้เป็น Solid



3.สร้าง Plane ขึ้นมาให้ได้ขนาดตามความต้องการ โดยกด  Space  ในหน้าต่าง Blank15x16.gif3D View

จากนั้นกด  Tab  เรียก Menu Add → Mesh → Plane
Cloth Menu Add → Mesh → Plane.png

เรียก Menu Add → Mesh → Plane



4.ใน Blank15x16.gif3D View ทำให้เป็นมุมมองแบบ perspective

หรือกด Blank15x16.gif5 (จะเป็นการสลับเรียกดูในมุม Perspective/Orthographic)แล้วคลิกลาก Blank15x16.gifM ใน Blank15x16.gif3D View เพื่อหมุนดูในมุมที่ต้องการ

จากนั้นใช้เครื่องมือ Rotate(Ctrl Alt R)คลิกซ้ายที่แกน X บน Plane หมุนให้ได้ฉากตามภาพ

การปรับ Plane ให้ได้ฉาก.png

การปรับ Plane ให้ได้ฉาก



5. ที่Blank15x16.gif3D View เปลี่ยนจาก Blank15x16.gifObject Mode เป็น Blank15x16.gifEdit Mode

Cloth เปลี่ยน Object Mode ให้เป็น Edit Mode.png

เปลี่ยน Blank15x16.gifObject Mode ให้เป็น Blank15x16.gifEdit Mode



6.ต่อไปจะเป็นการทำให้ Plane มีพื้นผิวที่เรียบเนียน ด้วยการเพิ่มจำนวน Polygon โดยการ ไปที่ Panel (Blank15x16.gifButtons Window) คลิกเลือก Blank15x16.gifEditing  F9  ที่ Mesh Tools คลิก Subdivide ซ้ำ ๆ จนกว่าจะได้จำนวน Polygon ที่พอเหมาะ(ถ้ายิ่งมากจะยิ่งเรียบเนียนมากขึ้น)

Cloth ใส่ Subdivide เพื่อให้ผิวเรียบเนียน.png

ใส่ Subdivide เพื่อให้ผิวเรียบเนียน


กำหนดบาง vertex เป็นจุดสำหรับขึงผ้า Edit

7.ที่ Blank15x16.gif3D View คลิกเลือก Vertex

Cloth คลิกเลือกการแก้ไขแบบ Vertex.png

คลิกเลือกการแก้ไขแบบจุด Vertex


8.เลือกจุด Vertex มุมบนสุดทั้งสองข้างของ Plane ด้วยการ คลิกขวาเมาส์Blank15x16.gifR เลือกจุดที่มุมบนซ้ายสุด จากนั้นกด  Shift  ค้างไว้ คลิกขวาเมาส์Blank15x16.gifR เลือกจุดที่มุมบนขวาสุด

Cloth เลือกจุด Vertex มุมบนสุดทั้งสองข้างของ Plane.png

ลือกจุด Vertex มุมบนสุดทั้งสองข้างของ_Plane



9.ต่อไปจะเป็นการเซ็ตจุด Vertex ที่เลือกไว้ ให้เป็น Group โดยการไปที่ Panel (Blank15x16.gifButtons Window) →Blank15x16.gifEditing  F9  ที่แถบ Link and materials คลิกเลือก New เพื่อสร้าง Group หลังจากที่คลิกเลือก New แล้วจะปรากฏแถบ Groupขึ้นมา เราสามารถตั้งชื่อว่าให้เป็น Group อะไรได้จากตรงนี้ โดยเฉพาะในกรณีที่มีหลาย Group จากนั้นคลิก Assign เพื่อเป็นการนำจุด Vertex ที่เลือกไว้ให้ไปอยู่ใน Group ที่สร้างขึ้น

Cloth การเซ็ตจุด Vertex ที่เลือกไว้ ให้เป็น Group.png

การเซ็ตจุด Vertex ที่เลือกไว้ให้เป็นGroup


ตั้งค่าให้โมเดลเป็นผ้า Edit

10.ต่อไปจะเป็นการทำให้ Plane ที่สร้างขึ้นนั้นเป็น Cloth โดยไปที่หน้าต่าง Panel (Blank15x16.gifButtons Window) คลิกเลือก Blank15x16.gifObject  F7  คลิกเลือก Blank15x16.gifPhysics buttons คลิกเลือก Cloth →Pinning of cloth

Cloth การทำให้ Plane เปลี่ยนไปเป็น Cloth.png

การทำให้ Plane เปลี่ยนไปเป็น Cloth



11.ที่ Blank15x16.gif3D View ออกจากโหมด Blank15x16.gifEdit Mode กลับสู่โหมด Blank15x16.gifObject Mode เป็นการจบส่วนผ้า

Cloth ปลี่ยน Edit Modeเป็น Object Mode.png

เปลี่ยน Edit Mode เป็น Object Mode


เตรียมแรงลมสำหรับพัดผ้าให้พริ้วไหว Edit

12.ต่อไปจะเป็นการสร้างแรงลม การจะสร้างลมได้นั้นต้องมีวัตถุอ้างอิง โดยวัตถุนั้นจะเป็นสี่เหลี่ยม สามเหลี่ยม หรือวงกลม อะไรก็ได้ ในการทดลองนี้ ใช้ Cube โดยการไปที่ ในหน้าต่าง Blank15x16.gif3D View จากนั้นกด  Tab  เรียก Menu Add → Mesh →Cube ปรับแต่งให้เหมาะสม โดยให้ Cube อยู่ห่าง จาก Plane พอประมาณ

Cloth เรียก Menu Add → Mesh → Cube.png

เรียก Menu Add → Mesh →Cube



13.เลือก Cube เสร็จแล้วไปที่ Panel (Blank15x16.gifButtons Window) คลิกเลือก Blank15x16.gifObject  F7  คลิกเลือก Blank15x16.gifPhysics buttons ที่แถบ Field คลิกเลือก Wind แล้วใส่ค่าแรงลมที่ Strength ตามต้องการ

Cloth การตั้งค่าลม.png

การใส่ลม


ดูผล Edit

14.ที่หน้าต่าง Blank15x16.gifTimeline → Playback คลิกเลือก Continue Physics

Cloth ตั้งค่าTimeline → Playback → Continue Physics.png

คลิกเลือกTimeline → Playback → Continue Physics



15. กดปุ่ม Play ในหน้าต่าง Blank15x16.gifTimeline

ไฟล์ทดลอง Edit


Cloth Tutorial Edit

Also on Fandom

Random Wiki