Fandom

Thai Blender Wiki

บทความ/ตกแต่งโมเดลด้วย Texture paint

< บทความ

105pages on
this wiki
Add New Page
Talk0 Share

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.

การตกแต่งโมเดลนั้นจะมีขั้นตอนที่สำคัญคือการคลี่ของผิวหน้าวัตถุ เพื่อจะได้ง่ายในการจัดแต่งพื้นผิว ซึ่งวิธีนี้จะทำให้สามารถจัดวางพื้นผิวที่มีความยืดหยุ่นสูง โดยการทดลองนี้นอกจากจะได้รู้วิธีคลี่โมเดลแล้ว ยังจะได้รู้จักกับ Material อีกด้วย โดยจะเป็นการเริ่มต้นทดลองแบบพื้นฐานเพื่อนำไปสู่การเรียนรู้ที่เข้าใจในขั้นตอนต่อ ๆ ไป
ซึ่งในการทดลองนี้ จะใช้ โมเดล Monkey โดยจะแบ่งเป็นขั้นตอนหลัก ๆ ดังนี้

  • ขั้นตอนการคลี่โมเดล
  • ขั้นตอนการสร้างไฟล์ภาพเพื่อจะนำไปใช้เป็น Texture
  • ขั้นตอนการสร้าง Material


ขั้นตอนการคลี่โมเดลEdit

ขั้นที่ 1Edit

ปรับหน้าต่างการทำงานเป็น 2 หน้าต่าง โดยหน้าต่างที่สองให้ปรับเป็น Blank15x16.gifUV/Image Editor ตามภาพ

Unwrap ปรับเป็น UV-Image Editor.png


ขั้นที่ 2Edit

สร้างหัวลิงขึ้นมาให้ได้ขนาดตามความต้องการ โดยกด  Space  ในหน้าต่าง Blank15x16.gif3D View จากนั้นกด  Tab  เรียก Menu Add → Mesh → Monkey

Softbody Menu Add → Mesh → Monkey.png

เรียก Menu Add → Mesh → Monkey


ขั้นที่ 3Edit

ที่Blank15x16.gif3D View เปลี่ยนจาก Blank15x16.gifObject Mode เป็น Blank15x16.gifEdit Mode

Cloth เปลี่ยน Object Mode ให้เป็น Edit Mode.png

เปลี่ยนBlank15x16.gifObject Mode เป็น Blank15x16.gifEdit Mode


ขั้นที่ 4Edit

ที่หน้าต่าง Blank15x16.gif3D View ให้กด  Ctrl E  คีย์บอร์ด เลือก Edge Loop Select โดยคำสั่งนี้จะเป็นการเลือกเส้นแบบต่อกันทั้งหมด

Unwrap คลิกเลือก Edge Loop Select.png

 Ctrl E  คีย์บอร์ด เลือก Edge Loop Select


ขั้นที่ 5Edit

จากนั้นให้กด  Alt Blank15x16.gifR  คลิกเลือกเส้นตรงกลางหัวลิงตามภาพ

Unwrap เลือกเส้น edge.png

 Alt Blank15x16.gifR  คลิกเลือกเส้น Edge


ขั้นที่ 6Edit

ที่หน้าต่าง Blank15x16.gif3D View ให้กด  Ctrl E  คีย์บอร์ดจะปรากฎชุดคำสั่งต่าง ๆ ให้เลือก Mark Seam เมื่อเลือกแล้วเส้นจะเปลี่ยนเป็นสีส้ม

Unwrap Mark Seam.png

 Ctrl E  → Mark Seam


ขั้นที่ 7Edit

กด  A  คีย์บอร์ด เพื่อเป็นการเลือกที่จะคลี่ทั้งหมด

Unwrap เลือกหัวลิงทั้งหมด.png

 A  คีย์บอร์ด เพื่อเป็นการเลือกทั้งหมด


ขั้นที่ 8Edit

จากนั้นกด  U  คีย์บอร์ด จะปรากฏชุดคำสั่งของ UV ขึ้นมา (ตรงนี้จะมีคำสั่งที่ใช้ในการคลี่ผิวหน้าโมเดลแบบอื่นอีกแต่จะนำมาทดลองในครั้งต่อไป) ให้คลิกเลือก Unwrap ซึ่งคำสั่งนี้ก็คือการคลี่ผิวหน้าโมเดลแบบหนึ่งนั่นเอง

Unwrap คลี่โพลีกอน.png

 U  คีย์บอร์ด คลิกเลือก Unwrap


ขั้นตอนการสร้างไฟล์ภาพเพื่อจะนำไปใช้เป็น TextureEdit

ขั้นที่ 9Edit

ในหน้าต่างBlank15x16.gifUV/Image Editor คลิกที่เมนู Image → New เพื่อที่จะสร้างไฟล์ภาพไปใช้เป็น Texture map

Unwrap เลือก Image New.png

คลิกที่เมนู Image → New


ขั้นที่ 10Edit

ที่หน้าต่าง Blank15x16.gif3D View ปรับ Draw Type เป็น Texture

Unwrap เลือก Texture.png

คลิกเลือกโหมดTexture


ขั้นที่ 11Edit

ยังอยู่ที่หน้าต่าง Blank15x16.gif3D View เปลี่ยนจาก Blank15x16.gifEdit Mode เป็น Blank15x16.gifTexture Paint

Unwrap เลือก Texture Paint.png

คลิกเลือกโหมดBlank15x16.gifTexture Paint


ขั้นที่ 12Edit

จะเห็นได้ว่า โมเดลหัวลิงจะเปลี่ยนเป็นสีดำ ซึ่งยากต่อการมองเห็นรายละเอียดต่าง ๆ ให้ไปที่เมนูบาร์ เลือก Render → Bake Render Meshes → Ambient Occlusion

Unwrap Render Ambient.png

ที่เมนูบาร์ เลือก Render → Bake Render Meshes → Ambient Occlusion


ขั้นที่ 13Edit

จากนั้นไปที่ Panel (Blank15x16.gifButtons Window) →Blank15x16.gifEditing  F9  ในแถบ Paint → Draw เราสามารถเลือกสีและปรับเปลี่ยนหัวพู่กันได้ตามความต้องการจากตรงนี้

Unwrap ปรับแต่งพู่กัน.png

เลือกสีและปรับเปลี่ยนหัวพู่กันในแถบ Panel (Blank15x16.gifButtons Window) →Blank15x16.gifEditing  F9  → Paint → Draw


ขั้นที่ 14Edit

ในหน้าต่าง Blank15x16.gif3D View ระบายสีลงบนโมเดลตามต้องการ

Unwrap ระบายสีลงโมเดล.png

ระบายสีลงบนโมเดล


ขั้นตอนการสร้าง Material เพื่อการเรนเดอร์Edit

ขั้นที่ 15Edit

ไปที่ Panel (Blank15x16.gifButtons Window) Blank15x16.gifShading  F5  คลิกเลือก Blank15x16.gifMaterial buttons จากนั้นในแถบ Links and Pipeline ให้คลิกเลือก Add New เพื่อเป็นการสร้าง Material

Unwrap Add New Material.png

Panel(Blank15x16.gifButtons Window) Blank15x16.gifShading  F5 Blank15x16.gifMaterial buttons→ Links and Pipeline → Add New


ขั้นที่ 16Edit

หลังจากที่ Add New แล้วจะปรากฏหน้าต่างเพื่อใส่ค่ารายละเอียดของ Material ในแถบ Panel Blank15x16.gifShading  F5 Blank15x16.gifMaterial buttons → Texture คลิกเลือก Add New เพื่อสร้าง Texture ขึ้นมา

Unwrap Add New Texture.png

Panel Shading (F5) → Material Buttons → Texture คลิกเลือก Add New


ขั้นที่ 17Edit

จากนั้นไปที่ Panel Blank15x16.gifShading  F5 Blank15x16.gifTexture buttons  F6  ในแถบ Texture ตรงโหมด Texture Type ให้เปลี่ยน None เป็น Image

Unwrap Texture Buttons Image.png

Blank15x16.gifTexture buttons  F6  → Texture → Texture Type เปลี่ยน None เป็น Image


ขั้นที่ 18Edit

เมื่อเปลี่ยน None เป็น Image แล้ว จะปรากฏแถบหน้าต่างเพิ่มขึ้นมา ซึ่งในขั้นตอนนี้เราจะไปนำไฟล์ภาพที่เราใช้พู่กันระบายลงบนโมเดลมาใช้ โดยไปที่แถบ Panel Image ให้คลิกตรงปุ่มหน้า Load เพื่อเลือกไฟล์ภาพ

Unwrap Texture Buttons Image Load.png

คลิกตรงปุ่มหน้า Load เพื่อเลือกไฟล์ภาพ


หลังจากเลือกไฟล์ภาพแล้วที่แถบ Panel Preview จะปรากฏภาพที่เรานำมาใช้
Unwrap Texture Buttons Image Preview.png

ไฟล์ภาพที่นำมาใช้จะปรากฏขึ้นในแถบ Panel Preview


ขั้นที่ 19Edit

หลังจากใส่ Texture แล้ว เมื่อทดลอง Render (F12) ดู ไฟล์ภาพที่เรานำมาใส่ในโมเดล อาจจะยังไม่ได้ตำแหน่งที่เราได้วาดไว้แต่แรก

Unwrap Render ไม่ใส่ UV.png

Texture ไม่ได้ตำแหน่งตรงตามที่วาดไว้แต่แรก



ให้ไปที่ Panel(Blank15x16.gifButtons Window) Blank15x16.gifShading  F5 Blank15x16.gifMaterial buttons ในแถบ Map Input ให้คลิกเลือก UV

Unwrap Material Buttons UV.png

ในแถบ Map Input ให้คลิกเลือก UV


เสร็จแล้วให้ลอง Render (F12) จะพบว่าหลังจากใส่ UV แล้ว ภาพที่นำมาใส่จะได้ตำแหน่งตามที่วาดไว้แต่แรก Unwrap Render ใส่ UV.png

Also on Fandom

Random Wiki